Ошибка при попытке подключить пакет pub get | Visual Studio Code | Dart

При подключении нового пакета и вызове команды packages get может возникнуть ошибка:

pub get
Resolving dependencies...
Got dependencies!
Cannot open file, path = '.\.packages' (OS Error: Отказано в доступе.
, errno = 5)
exit code 66

Для ее исправления, в свойствах файла снимите галочку "скрытый".

Решение проблемы https://github.com/flutter/flutter/issues/15711

При следующем вызове packages get ошибка может повториться. Это может происходить если вы используете Yandex.Диск и синхронизируете папку с облаком. В таком случае нужно отключить синхронизацию на папку с проектом.

Подборка заметок