Возможные проблемы при обновлении до версии Flutter Release Preview 2 и Dart SDK 2.1.0

Проблема с подключаемыми пакетами

Если Вы обновили Flutter SDK или Dart SDK до новой версии, то в существующих проектах могли получить ошибки с подключенными пакетами, к примеру:

Because flutter_app depends on validator any which requires SDK version <2.0.0, version solving failed.

Данная ошибка связана с подключаемым пакетом validator. Для ее исправления нужно посмотреть новую версию в официальном репозитории и поменять ее в файле вашего проекта pubspec.yaml.

После, нужно выполните обновление пакетов с помощью команды packages get.

На момент написания статьи мы не нашли официального обновления, но другие пользователи Гитхаба создали свои ветки с исправлениями.

Решение проблемы

Мы взяли изменения у пользователя Konnng, для того чтобы использовать его ветку, надо написать в pubspec.yaml:

Сохраняем проект, выполняем packages get. Теперь данной ошибки не должно быть.

Но рекомендуем вначале посмотреть обновления в официальном репозитории, а то вдруг оно уже появилось и работает.

Чтобы обновить Flutter SDK нужно выполнить flutter upgrade.

Проблема в новом проекте

Возможная ошибка при создании apk файла в новом проекте:

* Error running Gradle:
Exit code 1 from: D:\flutter\your_app\android\android\gradlew.bat app:properties:
Project evaluation failed including an error in afterEvaluate {}. Run with --stacktrace for >details of the afterEvaluate {} error.

FAILURE: Build failed with an exception.

* Where:
Build file 'D:\flutter\your_app\android\app\uild.gradle' line: 26

* What went wrong:
A problem occurred evaluating project ':app'.
> Could not resolve all files for configuration 'classpath'.
> Could not find lint-gradle-api.jar (com.android.tools.lint:lint-gradle-api:26.1.2).
Searched in the following locations:
https://jcenter.bintray.com/com/android/tools/lint/lint-gradle-api/26.1.2/lint-gradle-api-26.1.2.jar

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 21s

Finished with error: Please review your Gradle project setup in the android/ folder.

Решение проблемы

В файле flutter.gradle добавить строку: google()
Сам файл находиться в директории flutter, например
файл flutter.gradle
добавлнение строки: google()

flutter upgrade, ошибка

error: Your local changes to the following files would be overwritten by merge:
packages/flutter_tools/gradle/flutter.gradle
Please commit your changes or stash them before you merge.
Aborting

Если Вы воспользовались решением по проблеме которая описана выше: в файле flutter.gradle добавить строку google().
То теперь при обновление flutter может возникать проблема.
Для ее решения требуется сделать обратные действия и удалить строчку google(), в новом обновлении она уже будет, и добавлять ее не придеться.

Подборка заметок